
 
 
 
 
 
 
 
 
 

 

Semiconductor Optoelectronics, Vol. 43 No. 1 (2024), 186-193 
https://bdtgd.cn/ 

186 

SMART ENERGY MANAGEMENT AND NAVIGATION FRAMEWORK FOR 
AUTONOMOUS ELECTRIC VEHICLES IN COMPLEX ENVIRONMENTS 

 
Dr.M.Sangeetha 1, M.Ruba 2, R . Arunkumar 3 , G.Purushothaman4 , Viji .M 5, 

R.Shanthi 6 , Ramesh V 7 
1. Professor, EEE, sangee2maya@ gmail.com, M.A.M.SCHOOL OF ENGINEERING, 

Siruganur, Trichy-621105. 
2. Assistant Professor   , CSE ,  K.RAMAKRISHNAN COLLEGE OF ENGINEERING 

, Trichy. 
3. Assistant Professor, MECH, MRKIT, Kattumannar koil ,Tamilnadu ,India. 

4. Assistant Professor  , EEE, M.A.M.SCHOOL OF ENGINEERING, Siruganur,Trichy-
621105. 

5. PG Student, EEE, M.A.M.SCHOOL OF ENGINEERING, Siruganur,Trichy-621105. 
6. PG Student, EEE, M.A.M.SCHOOL OF ENGINEERING, Siruganur,Trichy-621105. 
7. PG Student, EEE, M.A.M.SCHOOL OF ENGINEERING , Siruganur,Trichy-621105. 
 
ABSTRACT 
Autonomous Electric Vehicles (AEVs) are revolutionizing the world of smart city 
transportation duet other lower source consumption, improved traffic efficiency, zero carbon 
emissions, and improved road safety. To ensure the safe passage of vehicles through a complex 
environment, it is essential to plan for safe and smart navigation and energy management for 
AEVs. This demands an effective model for locating the optimal Electric Charging Stations 
(ECS) for scheduling and recharging the AEVs when they run on low battery. Many research 
works, however, do not focus on navigation and scheduling policies for A EV charging that 
would occur in extreme events in complex environments. The electric vehicles are convenient 
technologies to reduce fuel cost and environmental emissions. The gas online price always 
comprises fluctuations but the electricity price is much more stable. The electricity price is also 
less expensive than gasoline. As a result, electric vehicles are 
conveniencetechnologiestoreducefuelcost.Theelectricitycostsandenvironmentalpollutionareth
eother targets that can be minimized by optimal charging-discharging of electric vehicles. The 
number of Electrical Vehicle (EV) charging stations is steadily increasing everyday as electric 
vehicles become more popular. With the proliferation of electric vehicles and their predicted 
sales growth in the near future, battery recharging will pose many challenges. In this paper we 
will introduce a smart power meter to recharge the electric vehicle. IOT technology is 
implemented to handle the electric vehicle (EV) recharging process. The proposed EV charging 
station draws current from the utility grid at low total harmonic distortion (THD).The optimal 
charging discharging pattern of electric vehicles reduces the economic cost of the unit 
commitment problem. 
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INTRODUCTION 
Autonomous Vehicles  
(AVs) have attracted a lot to fat tension as a technologically advanced and completely 
automated mode of transportation due to the significant advancements in computing 
technology and the automotive industry [1]–[3]. It is believed to be the next generation of smart 
transportation, with maximized safety and efficiency for smart energy management. AVs are 
rapidly being developed and transformed with 
electroniccontrolsandhavereplaced.Traditionaloperatingmechanisms, paving the way to a 
versatile framework for autonomous technologies. With the advent of sustainable energy 
developments, Electric Vehicles (EVs) are enhancing AVs in numerous ways that boost 
progression and development, are eco-friendly, and provide high efficiency. Due to its apparent 
advantages, such as low exhaustible petroleum resource usage, high efficiency, and low cost 
of ownership, the entire EV market has been increasing over recent years [4], [5]. With the 
integration of alternate renewable and clean energy sources, the emission of greenhouse gases 
can be minimized by using electric AVs. With the introduction of 6G, communication 
technology can leverage new speeds to decrease latency and improve throughput. This can 
address the various limitations in optimization problems that utilize comparatively slower 
network models [6]. AVs integrated with EVs, known as Autonomous Electric Vehicles 
(AEVs), could provide many advantages, from smart technology integration feasibility to cost 
efficiency and environmental friendliness. They make use of modern computational 
developments in technology and highly enhanced batteries to enable smart transportation 
solutions for passengers [7]. After a specific amount of time, the battery of the AEV starts to 
drain. The battery drainage rate depends upon several factors, such as the passenger and cargo 
load, the weight of the AEV, and the external temperature. To ensure that the AEVs reach their 
Destination with a sufficient battery, AEVs need to be recharged at Electric Charging Stations 
(ECS). Multiple ECSs are located in different locations and have different charging 
capabilities. Due to the restricted cruising range of vehicles, they need to make frequent stops 
for recharge during long journeys. Furthermore, AEVs need to find convenient charging 
stations and facilities for their optimal journey, a sin [8], with quick authentication to speed up 
the charging process [9]. An uncertain and complex environment, such as that of a disaster site, 
makes the transportation and navigation of vehicles strenuous and demanding due to dynamic 
obstacles. In such scenarios, blocked roads, fall entrees, traffic congestion, and other 
hindrances make finding convenient ECS a major concern. So far, existing literature has 
proposed solutions to optimizer outing and charge scheduling challenges for an urban 
environment with well-established infrastructure and simplified scenarios [10]. Considering 
these mobility characteristics, in particular, few studies have focused on realistic scenarios that 
involve the spatiotemporal dynamics of obstacles in motion and complex terrain. Moreover, 
recently Deep Reinforcement Learning (DRL) has been employed to make decisions in 
uncertain scenarios since an optimal strategy for the agents can be learned directly from 
experience data and does not require modeling the random distribution. However, very few 
models would help in planning for a fleet of vehicles, considering uncertain obstacles, traffic 
congestion in the road network, and the efficient total coverage of all charging stations. In this 
paper, we present a Collaborative Optimal Navigation and Charge Planning (CONCP) 
framework for a fleet of AEVs in a complex environment to overcome the aforementioned 
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challenges. We envision the fleet of AEVs navigating through a disaster site during evacuation 
and performing scheduling algorithms for optimal charging of AEVs. For this purpose, a Multi-
Agent Deep Deterministic Policy Gradient (MADDPG) algorithm based on Multi-Agent 
DRL(MADRL) has been formulated. The proposed CONCP model can effectively perform 
AEV navigation and charge scheduling despite as to chiastic environment. This is because the 
model can acquire observations from agents in the environment and [9] formulate an optimal 
model based on the information about the agent’s states and actions. The model is well-suited 
to a scenario in which many AEVs interact with their environment collaboratively to minimize 
the time taken for the journey and perform optimal navigation. The main contributions of this 
work are as follows: 1) Formulate an optimal routing model for a fleet of AEVs that offers a 
smart routing and energy management system while considering the peculiarities of the 
available charging station infrastructure, charging times, energy consumption, and 
optimization. 2) ADRL technique, namely the MADDPG algorithm, obtains the optimal 
scheduling strategy for a fleet of AEVs in a complex environment. 3) The collaborative model 
performs cooperative AEV navigation and charge planning ensuring guaranteed transportation 
for a fleet of vehicles. The rest of this paper is structured as follows. An overview of the 
literature study is presented in Section II. Section III describes the system model and the electric 
vehicle control dynamic so 
fanAEV.SectionIVputsforththeproposedCONCPframework.Thesimulationsetupandperforman
cecomparisonsoftheMADDPGto other existing cutting-edge algorithms. 
EXISTINGSYSTEM 
Electric vehicle charging station with charging port that charges electric vehicles and the 
charged voltage is displayed on LCD. In this system the bill pay mentis manual and in 
formation’s are not stored .EV can be slowly charged using a common 230 V / 16 A socket 
(single phase), it is not a desired approach as charging time will be too large, even for a whole 
night. According to Tesla, that connection only provides power but that will depend on the car 
use of a driver according to certain [8] variables such as distance to work and the type of driving 
activity. This can be scaled depending on many factors such as cost. 
DISADVANTAGES 
• Not efficient 
• Requires human intervention 
• Bill payment is manual 
 
PROPOSED SYSTEM 
Nowadays, fossil fuels are getting lesser and going to use up in future if continues consuming 
this high amount of fossil fuel. Other than that, environment is polluted because of green house 
gas emission from the burning of fossil fuel. Therefore, renewable energy is introduced and 
emphasized in many fields to reduce the usage of fossil fuel. Electrical vehicle technology is 
one of the important ways to reduce the usage of fossil fuel and very important in future when 
fossil fuel is used up. So, in future when there are more electrical vehicles is used, many petrol 
stations will change to EV charging stations. Hence this system proposes an IOT based smart 
power meter to recharge electric vehicle. In this system charging port [9] is used to charge the 
electric vehicle and measure the energy consumed by the vehicle during charging. RFID is 
used to make payment easy. The amount details are collected and bill payment is done by RFID 
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tag assigned to the person. The vehicle motor starts only after the bill payment. This system 
removes the transients and harmonics caused by electric vehicle charging through grid. The 
measured charging voltage with charging cost is uploading to the web server with the help of 
IOT and also displayed in LCD. 
ADVANTAGES 
• It is eco-friendly and requires less components to design. 
• RFID has used in this charging station to make easy payment there is no need to 
frequent maintenance. 
• Low power losses. 
• Possibility of  high-speed charging 
• No human intervention 
• Low maintenance requirements 

 
CIRCUIT DIAGRAM 
The Arduino integrated development environment (IDE) is a cross-platform application (for 
Windows, mac OS, Linux) that is written in the programming language Java. It is used to write 
and upload programs to Arduino board. The source code for the IDE is released under the GNU 
General Public License, version 2. The Arduino IDE supports the languages C and C++ using 
special rules of code structuring.[4]The Arduino IDE supplies a software library from the 
Wiring project, which provides many common input and output procedures. User-written code 
only requires two basic functions, for starting the sketch and the main program loop, that are 
compiled and linked with a programs tub main() in to an executable cyclic executive program 
with the GNU tool chain, also included with the IDE distribution. The Arduino IDE employs 
the program argued to convert the executable code into a text file in hexa decimal encoding 
that is loaded into the Arduino board by a loader program in 
theboard'sfirmware.Arduinoisanopen-sourceelectronicsplatformbasedoneasy-to-usehardware 
and software. Arduino boards are able to read inputs-light on a sensor, a finger on a button, or 
a Twitter message - and turn it into an output -activating a motor, turning on an LED, publishing 
something online. You can tell your board what to do by sending a set of instructions to the 
microcontroller on the board. 
PREPARING THE BOARD 
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Before loading any code to your Arduino board, you must first open the IDE. Double click the 
Arduino .exe file that you downloaded earlier. A blank program, or" sketch, "should open. The 
Blink example is the easiest way to test any Arduino board. Within the Arduino window, it can 
be found under File->Examples->Basics->Blink. Before the code can be uploaded [11] to your 
board, two important steps are required. 
1. Select your Arduino from the list under Tools->Board. The standard board used in RBE 
1001, 2001, and 2002 is the Arduino Mega 2560, so select the" Arduino Mega2560 or Mega 
ADK "option in the dropdown. 
2. Select the communication port, or COM port, by going to Tools->Serial Port. 
If you noted the COM port your Arduino board is using, it should be listed in the dropdown 
menu. If not, your board has not finished installing or needs to bere connected. 
 
LOADING CODE 
The upper left of the Arduino window has two buttons: A checkmark to Verify your code, and 
a right-facing arrow to Upload it. Press the right arrow but ton to compile and upload the Blink 
example to your Arduino board. The black bar at the bottom of the Arduino window is reserved 
forms sages indicating the success or failure of code uploading. A "Completed Successfully" 
message should appear once the code is done uploading to your board. If an error message 
appears instead, check that you selected the correct board and COM port in the Tools menu, 
and check your physical connections. If uploaded successfully, the LED on your board should 
blink on/off once very second .Most Arduino boards [15] have an LED pre wired to pin13.It is 
very important that you do not use pins 0 or 1 while loading code. It is recommended that you 
do not use those pin sever. Arduino code is loaded over a serial port to the controller. Older 
models use an FTDI chip which deals with all the 
USBspecifics.NewermodelshaveeitherasmallAVRthatmimicstheFTDIchiporabuilt-inUSB-to-
serialportontheAVRmicro-controlleritself. 
PRODUCT MODULES 
The Proteus Design Suite is a Windows application for schematic capture, simulation, and PCB 
(Printed Circuit Board) layout design. It can be purchased in many configurations, depending 
on the size of designs being produced and the requirements for microcontroller [14] simulation. 
All PCB Design products include an auto-router and basic mixed mode SPICE simulation 
capabilities. Alternate pairs of diodes conduct, changing over the connections so the alternating 
directions of AC are converted to the one direction of DC. 
Output: full-wave varying DC: (using the entire AC wave): 
 
VOLTAGE REGULATOR 
A voltage regulator is a circuit that creates and maintains a fixed output voltage, irrespective 
of changes to the input voltage or load conditions. Voltage regulators (VRs) keep the voltages 
from a power supply within a range that is compatible with the other electrical [12] 
components. While voltage regulators are most commonly used for DC/DC power conversion, 
some can perform AC/AC or AC/DC power conversion as well. This article will focus on 
DC/DC voltage regulators. 
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TESTREPORT 

 
ONCONDITION & OFF CONDITION 
CONCLUSION 
We have implemented a complete system to supervise the charging of EVs in car parks, using 
small and cheap microcontrollers connected to the Internet wirelessly. The proposed system 
allows a user to access the information associated with the charging process(cost, effective 
lapsed time, estimated time to full charge, etc.), and a supervisor to manage different aspects 
of the process such as billing of consumed energy, charging priorities, etc. This system aims to 
avoid power flow issues such as harmonics and losses. The use of an IOT connection 
dramatically reduces the wiring and the complexity of the installation, and simplifies the 
interaction with the users of the system. 
FUTUREENHANCEMENT 
Incorporating real-time weather data into the framework could enable the system to optimize 
the vehicle's energy management and navigation based on current weather conditions, such as 
rain, snow, or extreme temperatures. 
Theframeworkcouldbeenhancedtodynamicallyadjustthevehicle'srouteinresponse to changing 
traffic patterns, road closures, or accidents ,to ensure optimal energy management and timely 
arrival at the destination. The framework could be designed to monitor the vehicle's condition 
and performance in real-time, and use machine learning algorithms to predict when 
maintenance will be needed. This would enable the vehicle to be pro actively serviced to 
minimized own time and improve efficiency. Adding vehicle-to-vehicle communication 
capabilities to the framework could improve safety and energy efficiency. For example, 
vehicles could communicate with each other to avoid collisions, optimize traffic flow, and 
share information on available charging stations. The frame work could been handed to take 
advantage of renewable energy sources, such as solar or wind power, to recharge the vehicle's 
batteries. This would reduce the vehicle's carbon footprint and increase its range. The 
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framework could be designed to improve the user experience by providing more natural and 
intuitive interaction between the vehicle and the user. This could include voice commands, 
gesture recognition, or augmented reality interfaces. 
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